Taking mksysb image of an installed AIX system using NIM

From MyWiki

Jump to: navigation, search

On NIM client machine

First, run the following commands to clean out IP settings from ODM, so it doesn't make into the mksysb image (you hardly want to install a system off the mksysb and find that the original TCP/IP settings are getting in your way on first boot):

# /etc/rc.openssh stop
# umount /mnt/aixopt
# stopsrc -s automountd
# rmyp -c
# rmtcpip
# shutdown -Fr now

Then do TCP/IP configuration, using non-AIX commands, to prepare the machine for taking it's mksysb image

# ifconfig ...
# route ...
# cp /etc/resolv.conf.save /etc/resolv.conf
# refresh -s inetd

Check limits for root. fsize = -1 in /etc/security/limits.

On NIM master

Check the space available. Use chfs if necessary.

# nim -o define -t mksysb -a server=master -a location=/export/lpp_source/images/aix530_ml03_mksysb -a mk_image=yes -a source=freedom  -a comments='AIX 5.3 ml 03 with all Lab      related configs' aix530_ml03_mksysb
# nim -o change -a client_alloc=no aix530_ml03_mksysb

Create SPOT:

# nim -o define -t spot -a source=aix530_ml03_mksysb -a server=master -a location=/export/spot/aix530_ml03_mksysb_spot -a comments="SPOT resource created from aix530_ml03_mksysb" aix530_ml03_mksysb_spot

To install the image onto a NIM client system:

# nim -o bos_inst -a source=mksysb -a mksysb=aix530_ml03_mksysb -a spot=aix530_ml03_mksysb_spot -a boot_client=yes freedom 

In AIX 5.3 and later, NIM supports creating a SPOT from a mksysb resource.

Creating a SPOT from a mksysb resource allows you to only support the devices the mksysb uses. Because the SPOT only contains boot images for the devices in the source mksysb, it is significantly smaller than a SPOT created from an installation image. A SPOT that you create from a mksysb resource is typically 30 to 50 MB, whereas a SPOT that you create from an installation image is typically 300 MB. You also do not need an lpp_source resource with this method.

You should only use a SPOT created from a mksysb to perform bos_inst operations of the mksysb. Performing other operations on standalone clients, such as maint and diag is not supported. Performing cust operations on a SPOT taken from a mksysb is also not supported.

The mksysb_source attribute is used to distinguish a SPOT created from a mksysb from other SPOTs. The mksysb_source attribute is set to the resource name of the mksysb you used to create the SPOT. The mksysb that you create a SPOT from can be at any of the following AIX levels:

   * 4.3.3.75
   * 5.1.0.35
   * 5.1.0.50
   * 5.2.0.0
   * 5.2.0.10
   * 5.2.0.30
   * 5.3.0.0
# nim -o define -t spot -a source=mksysb1 -a server=master -a location=/export/spot spot1
Personal tools